Start a new topic

Sonoff firmware upgrade 1.2.0 to 1.5.0


Our 5 Sonoff switches are all connected and online to our router but the firmeware upgrade allways fails - what can be done?


9 people have this problem

- Uninstall the laest ewelink version.

- Install the oficial version of ewelink that you find in play/appstore.

- Start the app and NO upgrade in this moment.

- Now you can update the firmware device and when the work finish, you can upgrade the app too.

I hope I've helped.

I habe buy a dual sonoff , whit firmware 1.2.0. device is now registred on my acount working ok . but  it does not require update . say 120 is last version .



I hope the next one  helps for You all!

After 6 hours, spent trying to upgrage from 1.2 to 1.5  without any result - it stopped upgrading at 90% and said - it failed (I switched off alternative WIFI, pushed every possible buttons  in every possible ways, renamed device, upgraded, removed and installed eWeLink again...etc )
No result!!


At the end I simply removed/deleted the  device from my eWeLink app (android),  added/paired the device again and...pushed upgrade, and it was upgraded at once - tadaa!

That's all I think...

Good luck! :)


@toncsi King , tried that as well. this is for 1.5 -> 1.8 and no joy; on the S20 :(


I have the first version of Sonoff with 1.2 firmware, stuck on 90% when updating. I tried different ways

I tested with several different phones, also tested with a frequency of 2.4 ghz and phone hotspot but again, it is not possible to update the firmware.

Does anyone have a solution for updating the firmware?

(35.6 KB)
(35.3 KB)
(48 KB)
Login or Signup to post a comment