Start a new topic

Can't share to email address

Ewelink ver 2.1.4 for iOS. You can not share a device to an email address. Only to a mobile phone number.

10 people have this problem

I'd recommend anyone who's experiencing a problem with sharing the switches from the eWeLink app to open a support ticket as well as commenting in this forum, hopefully if enough people raise the issue something will get done.  

It seems to be a problem that's affecting everyone, I even spent an hour figuring out how to get the WeChat Sonoff web interface to work (not easy if you don't read Chinese) It might be useful too as WeChat runs on a PC or Mac as well as mobile devices so you can control things from your computer too.  But even there I'm still getting the 'Does not exist' message.

So far I've had my support ticket open for a couple of days and nothing has happened other than an automated response acknowledging it.  I've also tried the eWeLink Facebook group without any response.  I'm guessing it's the time of year in my case, but as there's messages here on the same issue going going back three weeks I'm not exactly filled with optimism right now.  Also the lack of any response from them in that time would suggest that despite the title, the content posted here isn't being monitored by anyone.

Well I got a response.  Basically "not our problem" use the feedback function in the app.  Which of course I did to begin with, had no response and thought I'd try here.   Next stop I guess it try them on Facebook.\

I have the same problem here.. I can't share the devices... Only I can control the devices at home and no one else. I have opened a ticket for the issue.

Sadly their stock response here is “f*** off, not our problem, use the feedback function in EWeLink”. Which is like a black hole for enquiries, I finally got a response from Facebook. Turns out that the email addresses I’d used to create the accounts were in different geographical locations some in the USA some In Europe and they only permit sharing on the same continent. I even found creating two addresses using the same provider with the same domain was no guarantee they’d be in the same geographical location. Plus there’s no way to tell where they’re located either, it’s simply pot luck! All I can advise is to keep setting up accounts using different email addresses until you find a couple that work.
I had some problem with this also, but managed to solve it by following the steps in the FAQ (Device Share Control section).

Basically there's no email confirmation code, and both devices must have the eWeLink app open at the same time when sharing.

I also logged off and logged on again on both devices to make sure the same country was selected on both devices - when I share a device in the app the country shown by default is the one I selected on login, but when I re-open the app after a while, the default changes to United States... could be a bug in the app that forgets the country after a while.
(using latest version eWeLink app for android)


Same problem here. I'm using EWeLink 3.3.3 and Sonoff Pow with with firmware 2.0.4. I'm trying to share this device with my son, but when I try to share with his email, I get the message: "Does not exist, please check".

I've tried with several ways: both cellphone with EweLink opened, with new accounting, same version, etc.

Someone helpme?


Both phones must be logged to ewelink to the share happen.

The problem for me lay with the email addresses used to create the accounts. Some were running on European servers whilst others were in the USA. For some reason EWeLink cannot handle that and from my experiments a “” extension guarantees nothing, perversely even two google email accounts created within minutes of each other on the same computer can be different and there seems to be no easy way of telling where your email account “resides” in the physical world. My advice would be to keep on making email/EWeLink accounts and trying them until you find two that work together. Hope this helps!
Typing the full email address worked for me. I had been using suggestive text which is similar to copy and pasting. Frustrating, but give it a try. Good Luck.

I found the Solution on their Chinese manual. It says both phones are need to be on line to get the share to work which means, your phone is sending the share command, your wife(whoever is receiving has to be on the ewelink app screen at the same time. 

email worked on me!!! hope it helps!!! Love ewelink!!!!

nice one.

Same issue here. I can't share a device to an account using the email address. Please fix this issue. I am using your devices at my small business and this is an issue for us. 

The other device must be with the ewelink app open as well! If not, will never work! 

To share device you must:

- Open ewelink app on your device

- Opend ewelink app in the other device that you want to receive the access shared

- Fill with the email to share and the other device will receive a message.

- Done!

I hope that helped!



I have tried creating 2 different accounts on Gmail. And 1 account on Yahoo. Neither worked for me. 

I have had BOTH the phones opened at the same time, and still unable to share. 

This should NOT be this difficult. There is a definite problem on ITEAD side. 

I have followed the instructions and it still doesn't work. I have created 2 accounts on GMAIL and one on Yahoo. Neither of the 3 accounts worked for me. I have both the phones in my hand running the software at the same time. 

Login or Signup to post a comment