Sonoff Devices Offline Troubleshooting

When you can power up the Sonoff products or other eWeLink supported products normally but fail to control it (offline), the first thing you should do is to check how the LED indicator of your product blinks. Mostly, the offline problem is caused by network connection.

Note: 1.If you change the wifi, you'll need to delete the devices, and re-add them via the new wifi, or they will be all offline.

2.One router can bear a limited number of devices (including phone, PC, smart devices), most routers can provide a normal wifi for about 15 devices, but if the wifi is poor, this will be reduced.

3.After successfully add devices, it doesn't matter what network your phone connects with. But if the wifi Sonoff products connect with is unstable, Sonoff devices will be easily become offline.

Usually, there are three kinds of blinking statuses(here we take the Sonoff Basic for example):

1. The LED indicator quickly blinks one time and repeats (blinks once every 2s), which means the device has failed to connect to the WiFi router.

2. The LED indicator quickly blinks twice and repeats, which means the device has connected to the router but fail to connect to the server.

3. The LED blinks once every 1s, and the device is offline.


The device has successfully connected to the router but hasn’t been added to the user’s account. Please power off the device and restart, then wait for a while. If the device is still offline, please delete it and re-add.


If you have deleted it and tried to re-add for several times but still failed, please try below:


Prepare another phone, enable its hotspot. Use your phone to connect the hotspot WiFi and add devices to eWeLink. If it is online successfully, this means that the problem is due to WiFi. Please check your router settings.

After judging the problem, you can troubleshoot the problems accordingly with below solutions.

Other Issues to Cause Offline Problem

Upgrading Firmware Causes Offline


In some conditions, upgrading firmware will cause MAC address change, then your device will become offline. Below is the firmware list that will cause MAC address change.

Firmware version   
 MAC address change when 
Upgrade to versions higher than 1.5.2
Upgrade to versions higher than 1.5.2
Upgrade to versions higher than 1.3.0
Upgrade to versions higher than 2.0.2
Upgrade to versions higher than 2.0.1

When this happens, please bind your device’s MAC address to your router’s binding list, as follows:

Go to Router Settings -> Close MAC Filter -> Connect your device to the router -> Add the device MAC address to the MAC Binding list -> Enable MAC Filter

If you don’t know about your firmware well, please submit a feedback on the App eWeLink. 

10 Solutions to Failed to Connect to the WiFi Router

1. Wrong WiFi Name or Password

You may have entered wrong WiFi name and password in the pairing process. Please delete the device and re-add. Please make sure you have entered them exactly and select remember password. 

2. Weak WiFi Signal

Your device may be too far away from the router, which causes a weak WiFi signal. Please try again with stronger WiFi signal.

Note: our devices can't connect to 5G WiFi, only 2.4G WiFi supported.


3. Phone Unable to Connect to WiFi

Your router or phone may come across some error, which causes a connection failure. Please make sure your phone can access the WiFi router and works normally. If your phone has WiFi network in the Access Point but the device still fails to connect to the router, please refer to below solutions.


4. Too many devices connect to the AP

There might be too many devices connect to the AP which connects to with the router, please turn off the devices or turn off the AP and try again 


5. Too Many Connections to One Router

You may have too many devices connecting to one router. Most of the routers have connection limit. Please disconnect other devices, then power off and restart your device.

6. Change DHCP Settings

You may have too many devices connecting to one router. Please reset DHCP address pool in router settings, then power off and restart the device to connect again.


7. Router Error

Router error. Please restart your router and try again.


8. MAC Address Prohibited

For some security reason, your MAC address may be filtered and prohibited. Under such a condition, you should remove it from the prohibited address list.


9. MAC Address Conflict

Close all other connected devices to this router and try again.

10. DHCP tenancy term problem

Prohibit DHCP or extending DHCP tenancy term when DHCP is open. 

Under the condition of disabled DHCP or open DHCP, you can extend the lease.

* eWeLink keeps prompting “Network Unavailable”, what to do?

Please ping our server URLs on your PC:
If your location is in Asia:,,
If your location is in EU:,,
If your location is in Oceania:,,,,
If your location is North Ameria or South America:,,
How to ping? Check this tutorial.
If the result shows the connection between the server and WiFi is well, your network is OK.
If the result shows the connections is bad, please change your phone’s DNS to
Still failed? Please change router’s DNS to, then ping the corresponding URL again.
If the result shows the IP addresses don’t run, please send the related URL to your network operator, let them help you. For example, if you are Asian user, please ask the network operator to parse these two domains:,, and


8 Solutions to Failed to Connect to Server

We are upgrading the server or there exists server error. If the server is running normally. Please check below:

1. Unable to Visit the Internet

If the extranet cannot be accessed, then use your phone or PC to visit the Internet. If successful, try to connect your device again.

If you have stopped paying Internet fee or extending your network service, your can’t visit the Internet.


2.Bandwidth Occupied

You may have downloaded too many files at the same time, which occupied most of the bandwidth, thus your device did not have enough bandwidth to connect to the server. If so, please stop downloading and try to re-add your device.

If your other apps can be run normally, only eWeLink display offline, the problem should be your wireless carrier can’t resolve the address of eWeLink server. Please manually change DNS to or, then re-connect.


3.More than one router with the same SSID (name)

You may have more than one router with the same name, and your device may have connected to the non-networked one. In this case, you should reset your router name and choose the networked one to connect. Then try to connect your device again.


4.More than one DHCP server on one network 

There may be errors existing between router topology. In this case, please check the connection way between routers, then try again.


5.ARP Attacked

If you have checked all above and found them no problems, maybe some terminal of the local area network you are locating has affected ARP virus. We suggest you to manually bind gateway and MAC address, then try again.


6.Firewall Settings

You may have opened firewall or some security software. In this case, please temporarily close them and try to connect the device again.


7.DNS Server Inaccessible

After making all above checks and finding them no problems, the possible problem should be DNS error. Please manually change DNS server address and try again.

After making all above checks and find no problems but still failed, the possible problem should be DNS error. Please manually change DNS server address to Then try to re-add your device.

8. IP address conflict

Please close all other connections that connect to the router. Then try to re-add your device.

9. Ping server address to check if server is normal

You can also ping our server address on your computer. Please select the server address according to your location. Then send the result to our support. If you don't know how to ping, please check this post (




Please submit a feedback on eWeLink, describe your problem in details. If you have a hardware problem, please submit a new ticket in our Smart Home Forum. We will follow up on your ticket. 

Our support will deal with your issue as soon as possible in working time. Our working time is Monday ~ Friday, 9:00 to 18:00 Beijing time, Time Zone:8. 

3 people like this

My thanks to Denis as well. I've been using these switches for a few months now and to be fair this is the first time I've experienced problems, however the lack of notification of the issue was inexcusable. The switches I have fitted to lights aren't to much of a problem (although they are in the bedroom so I wasn't to happy being woken by the "Disconection Disco", but one also controls my not water heater which is more of a concern. Server stability and local control options should be high priorities and addressed quickly, but by necessity will take time. There is no excuse for not committing immediately to improved standards of issue notification.

I have been monitoring mine a little closer for the past few days and it tends to drop connection at approx. 11.30 am (uk) then not come back until late afternoon. as yet I have not lost connection during the night time or evening.

1 person likes this

also it has dropped out again today (approx. 11.30 am)

1 person likes this
It seems to be working now, but it seems that history function/option/information is missing as a result of server problems. And not talking about history one month or one week ago , but real time processes are not recorded or saved anymore. I have 3 wall receptacle switches, 3 S1 basic switces, couple low voltage restart switches and RF bridge with magnetic door alarms. First noticed it from door alarms, because the app prompts you to check history (in case of an alarm) but nada - "nothing to see". So I noticed that no history data is available for other switches also. The second thing that attracted my attention is although devices were offline for the app, they still functioned (because of preprogrammed timers) and were able to send their status changes to the AWS  and these messages were then relayed to the Ewelink app.


Hi all , I am in Dublin Ireland and have had sonoff products for the past 12 months , for the past few days it has done my head in, Thanks for the update Dennis very much appreciated.

All my devices are currently offline  

It's always a problem when you depend from someone else...

Here, SONOFF devices depend from a cloud service in charge of ITEAD Studio...

The best solution is to have its own complete system and reprogramming the SONOFF as an ESP8266 and piloting it directly from your server is certainly the best...

I can't trust longer in ITEAD Studio capabilities.... Sorry...

Hm… Is it possible to change (temporary of course) server address to or in LAN settings? Will it work with another area's server?

I’m fairly new to the sonoff basic WiFi switches. They worked really well for a number of weeks recently they keep loosing connection to the server according to the lights on all 6 of the switches blinking twice. Can you tell me if this is a regular thing? I’m in the process of updating my home to smart stuff using things with Alexa and these looked perfect. I’m not so sure now. If this keeps happening can I please get a refund and I’ll have to go for something more expensive and reliable? I’m in the UK, I have very good WiFi throughout the house. Even the iOS app won’t load today. Thanks Lee
I'm in Dublin.. which seems to be worse affected as devices are offline the last 2 days, as it's only the EU that seems to be affected I decided to delete the devices from the app, logged out and logged back in but used the US dialling code... on the login screen, this must be where the ITEAD server is selected based on your location, re added the devices and they are now all online.
Hi Jason That sounds promising, could you give more detail on how to do this?
Just worked it out, mine too connected straight away, thanks for the info

Pls, don't DDOS the US server too! =)

Io ho provato con il suggerimento di Jason, ma non è cambiato assolutamente nulla

The us server was fine yesterday on both EWeLink app and Alexa app. Today however works fine on EWeLink (any server) but Alexa EWeLink skill shows server unresponsive. I have tried logging off on both deleted devices, finds all again on EWeLink but no longer on Alexa. There was an Alexa update today i wonder if this caused a problem?

I can not believe when I read these, but I just got a my switch today and I connected via the app. switch function work, but  when I try connected on google home, like the others.

Login or Signup to post a comment