Sonoff Devices Offline Troubleshooting

When you can power up the Sonoff products or other eWeLink supported products normally but fail to control it (offline), the first thing you should do is to check how the LED indicator of your product blinks. Mostly, the offline problem is caused by network connection.

Note: 1.If you change the wifi, you'll need to delete the devices, and re-add them via the new wifi, or they will be all offline.

2.One router can bear a limited number of devices (including phone, PC, smart devices), most routers can provide a normal wifi for about 15 devices, but if the wifi is poor, this will be reduced.

3.After successfully add devices, it doesn't matter what network your phone connects with. But if the wifi Sonoff products connect with is unstable, Sonoff devices will be easily become offline.

Usually, there are three kinds of blinking statuses(here we take the Sonoff Basic for example):

1. The LED indicator quickly blinks one time and repeats (blinks once every 2s), which means the device has failed to connect to the WiFi router.

2. The LED indicator quickly blinks twice and repeats, which means the device has connected to the router but fail to connect to the server.

3. The LED blinks once every 1s, and the device is offline.


The device has successfully connected to the router but hasn’t been added to the user’s account. Please power off the device and restart, then wait for a while. If the device is still offline, please delete it and re-add.


If you have deleted it and tried to re-add for several times but still failed, please try below:


Prepare another phone, enable its hotspot. Use your phone to connect the hotspot WiFi and add devices to eWeLink. If it is online successfully, this means that the problem is due to WiFi. Please check your router settings.

After judging the problem, you can troubleshoot the problems accordingly with below solutions.

Other Issues to Cause Offline Problem

Upgrading Firmware Causes Offline


In some conditions, upgrading firmware will cause MAC address change, then your device will become offline. Below is the firmware list that will cause MAC address change.

Firmware version   
 MAC address change when 
Upgrade to versions higher than 1.5.2
Upgrade to versions higher than 1.5.2
Upgrade to versions higher than 1.3.0
Upgrade to versions higher than 2.0.2
Upgrade to versions higher than 2.0.1

When this happens, please bind your device’s MAC address to your router’s binding list, as follows:

Go to Router Settings -> Close MAC Filter -> Connect your device to the router -> Add the device MAC address to the MAC Binding list -> Enable MAC Filter

If you don’t know about your firmware well, please submit a feedback on the App eWeLink. 

10 Solutions to Failed to Connect to the WiFi Router

1. Wrong WiFi Name or Password

You may have entered wrong WiFi name and password in the pairing process. Please delete the device and re-add. Please make sure you have entered them exactly and select remember password. 

2. Weak WiFi Signal

Your device may be too far away from the router, which causes a weak WiFi signal. Please try again with stronger WiFi signal.

Note: our devices can't connect to 5G WiFi, only 2.4G WiFi supported.


3. Phone Unable to Connect to WiFi

Your router or phone may come across some error, which causes a connection failure. Please make sure your phone can access the WiFi router and works normally. If your phone has WiFi network in the Access Point but the device still fails to connect to the router, please refer to below solutions.


4. Too many devices connect to the AP

There might be too many devices connect to the AP which connects to with the router, please turn off the devices or turn off the AP and try again 


5. Too Many Connections to One Router

You may have too many devices connecting to one router. Most of the routers have connection limit. Please disconnect other devices, then power off and restart your device.

6. Change DHCP Settings

You may have too many devices connecting to one router. Please reset DHCP address pool in router settings, then power off and restart the device to connect again.


7. Router Error

Router error. Please restart your router and try again.


8. MAC Address Prohibited

For some security reason, your MAC address may be filtered and prohibited. Under such a condition, you should remove it from the prohibited address list.


9. MAC Address Conflict

Close all other connected devices to this router and try again.

10. DHCP tenancy term problem

Prohibit DHCP or extending DHCP tenancy term when DHCP is open. 

Under the condition of disabled DHCP or open DHCP, you can extend the lease.

* eWeLink keeps prompting “Network Unavailable”, what to do?

Please ping our server URLs on your PC:
If your location is in Asia:,,
If your location is in EU:,,
If your location is in Oceania:,,,,
If your location is North Ameria or South America:,,
How to ping? Check this tutorial.
If the result shows the connection between the server and WiFi is well, your network is OK.
If the result shows the connections is bad, please change your phone’s DNS to
Still failed? Please change router’s DNS to, then ping the corresponding URL again.
If the result shows the IP addresses don’t run, please send the related URL to your network operator, let them help you. For example, if you are Asian user, please ask the network operator to parse these two domains:,, and


8 Solutions to Failed to Connect to Server

We are upgrading the server or there exists server error. If the server is running normally. Please check below:

1. Unable to Visit the Internet

If the extranet cannot be accessed, then use your phone or PC to visit the Internet. If successful, try to connect your device again.

If you have stopped paying Internet fee or extending your network service, your can’t visit the Internet.


2.Bandwidth Occupied

You may have downloaded too many files at the same time, which occupied most of the bandwidth, thus your device did not have enough bandwidth to connect to the server. If so, please stop downloading and try to re-add your device.

If your other apps can be run normally, only eWeLink display offline, the problem should be your wireless carrier can’t resolve the address of eWeLink server. Please manually change DNS to or, then re-connect.


3.More than one router with the same SSID (name)

You may have more than one router with the same name, and your device may have connected to the non-networked one. In this case, you should reset your router name and choose the networked one to connect. Then try to connect your device again.


4.More than one DHCP server on one network 

There may be errors existing between router topology. In this case, please check the connection way between routers, then try again.


5.ARP Attacked

If you have checked all above and found them no problems, maybe some terminal of the local area network you are locating has affected ARP virus. We suggest you to manually bind gateway and MAC address, then try again.


6.Firewall Settings

You may have opened firewall or some security software. In this case, please temporarily close them and try to connect the device again.


7.DNS Server Inaccessible

After making all above checks and finding them no problems, the possible problem should be DNS error. Please manually change DNS server address and try again.

After making all above checks and find no problems but still failed, the possible problem should be DNS error. Please manually change DNS server address to Then try to re-add your device.

8. IP address conflict

Please close all other connections that connect to the router. Then try to re-add your device.

9. Ping server address to check if server is normal

You can also ping our server address on your computer. Please select the server address according to your location. Then send the result to our support. If you don't know how to ping, please check this post (




Please submit a feedback on eWeLink, describe your problem in details. If you have a hardware problem, please submit a new ticket in our Smart Home Forum. We will follow up on your ticket. 

Our support will deal with your issue as soon as possible in working time. Our working time is Monday ~ Friday, 9:00 to 18:00 Beijing time, Time Zone:8. 

3 people like this

In the UK.  My Sonoff devices were all working fine yesterday.  Today, they are all showing as offline and are flashing indicating that they failed to connect to the server.  I have checked the network and pinged the servers with no problem, but they will not connect to the servers, even after being turned off and on for a period.  I assume this means that the severs are down, but there is no notice if this.  When will they be up again?

2 people like this

Exactly the same here in France... 

At the moment the led is not blinking, but the app is not able to turn on or off the SONOFF module...

The SONOFF have a very good hardware, but a very poor server software and all the SONOFF solution is not usable....

Graeme. I am also in the UK with exactly the same situation.  Yesterday OK.  Today all devices hunting for the server.

Itead need to tell us what's going on before we all refuse to buy their products again.

ok. in italy now my 3 switch are ok
One more time everything down.Really bad service

Odd - Suddenly the devices have all connected and are working again. Although I would obviously prefer there to not be any down-time, I do think there needs to be some means of notifying us if there is a problem with the servers planned or not, preferably with some notice if it is planned maintenance. 

I haven't had my Sonoff devices long, but I hope this is temporary and is not a sign how it will be.

I have 3 light switches and 3 s20 sockets for about 3 weeks, all were working fine until Xmas and since then almost every day lose connection to the server, if i had not thrown away the boxes i would send back to amazon.

Ho lo stesso problema, hanno funzionato soltanto il primo giorno (28 dicembre), poi continue interruzioni causate dal server. Anche adesso sono inutilizzabili, penso che restituirò ad amazon.

Could this be a case of a sudden popularity of these products overwhelming the server?
I have just raised a support ticket and asked the following: Hi I have 3 son off light switches and 3 s20 sockets all were working fine for approx 2 weeks. Since Christmas they constantly lose connection to the server, almost daily then if left the connect later and are fine. They all have latest software installed, i have re installed app and tried on another router. Looking at the forum many people are having this issue world wide, can you advise what is being done to resolve this, Regards Dennis

1 person likes this

Ho-ho! Got the same in Russia couple hours ago. %)

Host was available.

Local wi-fi && Inet uplink was Ok. Sonoff devices' LEDs (s20, th16, etc) showed good connect to the server (steady light). eWeLink app (Android) showed "unavailable nettwork" in devices' settings.

But right now everything is ok. Looks like servers are under construction?

I had this reply from tech support: We'd like to give you some additional information about the service disruption that occurred in the European Union Region recently. The cloud server was deployed on Amazon AWS Germany since mid 2015. With the rapid growth of users and devices, the servers load are under high load. Upgrading the server and server shortly after the New Year holiday was planned. Unfortunately the server went down on 1st Jan, 2018. When the servers came online again 4 hours later, millions of devices request https connectioån at the same time. The servers were working under considerably high load. What makes it worse was the servers were under DDOS attack during these few days. We found some bugs that cannot be found under low load. Coordinate mechanism between the server and the devices should be upgraded as well. After been full tested, the EU server will be upgraded in Mid Jan. Come along with More powerful AWS servers, upgraded server architecture, improved attack protection, and better coordinate mechanism. Finally, we want to apologize for the inconvenient caused for our customers. We will do everything we can to learn from this event and use it to improve our availability even further.

1 person likes this

Thank you Dennis for sharing that with us.   My devices have been working since they came back online, however, I am now having trouble with the link to Google Home.  The linking of the Smart We Link service to Google Home works and shows the devices, but when I try to get Google to switch them, the response is  "Sorry there was an error and I am unable to control your home device".  The devices do work fine from the eWeLink app.  I wonder if that is related.

Another thank you Dennis for sharing your response - that is the most information we've had about the current situation so far.  I have been following the facebook page which has been lacking!

I've been a user of Sonoff devices for must be 12 months now and up till now have been very impressed.   I can accept problems with the service but what I find very disappointing is a lack of communication.  I hope this improves or I will have to look for alternative products.

As to current status - my ewelink app is currently fully functional although was showing no network earlier this morning, my devices work with Alexa but IFTTT functionality is still down.

Confirming that IFTTT is still down. It seems that reply to Denis is now official status

Login or Signup to post a comment