Sonoff Devices Offline Troubleshooting

When you can power up the Sonoff products or other eWeLink supported products normally but fail to control it (offline), the first thing you should do is to check how the LED indicator of your product blinks. Mostly, the offline problem is caused by network connection.

Note: 1.If you change the wifi, you'll need to delete the devices, and re-add them via the new wifi, or they will be all offline.

2.One router can bear a limited number of devices (including phone, PC, smart devices), most routers can provide a normal wifi for about 15 devices, but if the wifi is poor, this will be reduced.

3.After successfully add devices, it doesn't matter what network your phone connects with. But if the wifi Sonoff products connect with is unstable, Sonoff devices will be easily become offline.

Usually, there are three kinds of blinking statuses(here we take the Sonoff Basic for example):


1. The LED indicator quickly blinks one time and repeats (blinks once every 2s), which means the device has failed to connect to the WiFi router.



2. The LED indicator quickly blinks twice and repeats, which means the device has connected to the router but fail to connect to the server.


3. The LED blinks once every 1s, and the device is offline.

image



The device has successfully connected to the router but hasn’t been added to the user’s account. Please power off the device and restart, then wait for a while. If the device is still offline, please delete it and re-add.

 

If you have deleted it and tried to re-add for several times but still failed, please try below:

 

Prepare another phone, enable its hotspot. Use your phone to connect the hotspot WiFi and add devices to eWeLink. If it is online successfully, this means that the problem is due to WiFi. Please check your router settings.




After judging the problem, you can troubleshoot the problems accordingly with below solutions.


Other Issues to Cause Offline Problem


Upgrading Firmware Causes Offline

 

In some conditions, upgrading firmware will cause MAC address change, then your device will become offline. Below is the firmware list that will cause MAC address change.


Firmware version   
 MAC address change when 
FWSW-01
Upgrade to versions higher than 1.5.2
FWSW-0185
Upgrade to versions higher than 1.5.2
FWSWES-04
Upgrade to versions higher than 1.3.0
FWSW-01P
Upgrade to versions higher than 2.0.2
FWSW-01TH
Upgrade to versions higher than 2.0.1


When this happens, please bind your device’s MAC address to your router’s binding list, as follows:

Go to Router Settings -> Close MAC Filter -> Connect your device to the router -> Add the device MAC address to the MAC Binding list -> Enable MAC Filter

If you don’t know about your firmware well, please submit a feedback on the App eWeLink. 




10 Solutions to Failed to Connect to the WiFi Router


1. Wrong WiFi Name or Password

You may have entered wrong WiFi name and password in the pairing process. Please delete the device and re-add. Please make sure you have entered them exactly and select remember password. 


2. Weak WiFi Signal

Your device may be too far away from the router, which causes a weak WiFi signal. Please try again with stronger WiFi signal.

Note: our devices can't connect to 5G WiFi, only 2.4G WiFi supported.

 

3. Phone Unable to Connect to WiFi

Your router or phone may come across some error, which causes a connection failure. Please make sure your phone can access the WiFi router and works normally. If your phone has WiFi network in the Access Point but the device still fails to connect to the router, please refer to below solutions.

 

4. Too many devices connect to the AP

There might be too many devices connect to the AP which connects to with the router, please turn off the devices or turn off the AP and try again 

 

5. Too Many Connections to One Router

You may have too many devices connecting to one router. Most of the routers have connection limit. Please disconnect other devices, then power off and restart your device.


6. Change DHCP Settings

You may have too many devices connecting to one router. Please reset DHCP address pool in router settings, then power off and restart the device to connect again.

 

7. Router Error

Router error. Please restart your router and try again.

 

8. MAC Address Prohibited

For some security reason, your MAC address may be filtered and prohibited. Under such a condition, you should remove it from the prohibited address list.

 

9. MAC Address Conflict

Close all other connected devices to this router and try again.


10. DHCP tenancy term problem


Prohibit DHCP or extending DHCP tenancy term when DHCP is open. 

Under the condition of disabled DHCP or open DHCP, you can extend the lease.


* eWeLink keeps prompting “Network Unavailable”, what to do?


Please ping our server URLs on your PC:
If your location is in Asia:
cn-long.coolkit.cc, cn-api.coolkit.cc, api.coolkit.cc.
If your location is in EU:
eu-long.coolkit.cc, eu-api.coolkit.cc, api.coolkit.cc.
If your location is in Oceania:
cn-long.coolkit.cc, cn-api.coolkit.cc, api.coolkit.cc.
eu-long.coolkit.cc, eu-api.coolkit.cc, api.coolkit.cc.
If your location is North Ameria or South America:
cn-long.coolkit.cc, cn-api.coolkit.cc, api.coolkit.cc.
How to ping? Check this tutorial.
If the result shows the connection between the server and WiFi is well, your network is OK.
If the result shows the connections is bad, please change your phone’s DNS to 119.29.29.29.
Still failed? Please change router’s DNS to 119.29.29.29, then ping the corresponding URL again.
If the result shows the IP addresses don’t run, please send the related URL to your network operator, let them help you. For example, if you are Asian user, please ask the network operator to parse these two domains: cn-long.coolkit.cc, cn-api.coolkit.cc, and api.coolkit.cc.


 

8 Solutions to Failed to Connect to Server


We are upgrading the server or there exists server error. If the server is running normally. Please check below:


1. Unable to Visit the Internet

If the extranet cannot be accessed, then use your phone or PC to visit the Internet. If successful, try to connect your device again.

If you have stopped paying Internet fee or extending your network service, your can’t visit the Internet.

 

2.Bandwidth Occupied

You may have downloaded too many files at the same time, which occupied most of the bandwidth, thus your device did not have enough bandwidth to connect to the server. If so, please stop downloading and try to re-add your device.


If your other apps can be run normally, only eWeLink display offline, the problem should be your wireless carrier can’t resolve the address of eWeLink server. Please manually change DNS to 223.5.5.5 or 223.6.6.6, then re-connect.

 

3.More than one router with the same SSID (name)

You may have more than one router with the same name, and your device may have connected to the non-networked one. In this case, you should reset your router name and choose the networked one to connect. Then try to connect your device again.

 

4.More than one DHCP server on one network 

There may be errors existing between router topology. In this case, please check the connection way between routers, then try again.

 

5.ARP Attacked

If you have checked all above and found them no problems, maybe some terminal of the local area network you are locating has affected ARP virus. We suggest you to manually bind gateway and MAC address, then try again.

 

6.Firewall Settings

You may have opened firewall or some security software. In this case, please temporarily close them and try to connect the device again.

 

7.DNS Server Inaccessible

After making all above checks and finding them no problems, the possible problem should be DNS error. Please manually change DNS server address and try again.


After making all above checks and find no problems but still failed, the possible problem should be DNS error. Please manually change DNS server address to 119.29.29.29. Then try to re-add your device.


8. IP address conflict

Please close all other connections that connect to the router. Then try to re-add your device.


9. Ping server address to check if server is normal

You can also ping our server address on your computer. Please select the server address according to your location. Then send the result to our support. If you don't know how to ping, please check this post (https://iihelp.iinet.net.au/How_to_run_a_ping_test).

EU: 

eu-disp.coolkit.cc

Asia:

cn-disp.coolkit.cc

US: 

us-disp.coolkit.cc


Please submit a feedback on eWeLink, describe your problem in details. If you have a hardware problem, please submit a new ticket in our Smart Home Forum. We will follow up on your ticket. 

Our support will deal with your issue as soon as possible in working time. Our working time is Monday ~ Friday, 9:00 to 18:00 Beijing time, Time Zone:8. 





3 people like this

Disconnect power for a minute then restore. If doesn’t help remove switch from the app, then readd by starting pairing again

Looky-Xu 

That was no help. I know how to reset and read codes. Im getting 4 flashes on and 1 off (may be 5 on 1 off but too quick to see)

No where in your post is that code mentioned.

And yes I have done power off etc etc, thanks.

Sorry I was not able to help you. In this case you need to submit a ticket with the Sonoff team (you can do it from the app) If they can’t help, open a ticket with ITEAD support team. PS. Inunderstand that after you have removed the divice you were nit able to re-add again right?

Correct.

Not able to re-add .

I will do as you suggest.

Switch has probably died and needs to be disposed.

Per the comment on lights above from Elliot; I never had lights flash , go solid after connected when they are working ok.   Is there different versions ?  Is there a button combination to know its not connected-not paired.
I have one slamper that pair, connect but still does not link to server and never gets to wifi- . Dead. 
 

 

The Sonoff BAsic has a  light to tell you your offline . So there is smarts inside to give me a (signal) contact out that I 'lost wifi; router, isp etc..
Can I get to that for a hard contact out so I can trigger a relay to reset-repower my router ?

 Any other devices can provide this ?

what a shit procuct .. wished I had never bougt it. Tried for hours read many items for hours but the F....G things won't work !! 


DOES NOT WORK THIS CRAP !!

I understand you are flustrated but this will not resolve your problem. Can you provide more details reg your issue? I have entire house installed with Sonoff switches all types incl old std EU and new UK RF so maybe can help you? I have a very good opinion about this product but I know that sometimes you can buy a faulty one. I have replaced already 4 switches due to fault (one even twice) out of the box. Even reported this to Itead as quality check issue

1 person likes this
What rf315 module works with the 3gang wall sw.? The one lazada has to copy or learn, does nothing
Thanks.   Maybe one that does not work. Since there is no beeps, lights etc to tell you its paired and learned; you have no idea ?
So it could be a copy one Lazada sells as they have a clueless staff about everything.   I need to get one from Itead directly that works with the  RF315  frequency.
There is no doc's in the box to say how to pair with the RF; its like it does not exist.   Even the RF remote ordered has  NO papers with it.

The 3 gang wall plate is great !   Love it but I have to add an external box around the plate that is larger that before.
I've had  replies from Itead support asking me where I've seen that this wall plates even uses RF ?
OMG; right on the papers, directions and some Tech staff asks this ?

 

I also had to get my Velop  by Linksys;  Mesh router to connect to the  2.4  vs.  5  mhz  as it won't work on  5  mhz.
no problem as its in a config to select   2.4 only.

 

 One Slampher wall socket not working;  in part.  I can pair; The RF remote work but won't go online with my phone

Its a faulty unit as all others work fine in same conditions.   So there should be a beep, light as the first think to say its connected ok to the wifi -router. ? IMO.

2. Add a beep to say it paired-learned codes to the remote.  Or come up with a new remote with lights to tell you.




Filip : thanks.. after lots of trying I get the switch in my app. But it stays off line. Swith is about 1 meter from the router.  It's second one I tried 

image


Hi Marcel,

First of all, remove the glass panel and find a reset button (red microstick). Press firmly once. It will reboot the device.

Is it RF switch? If so, try compatible mode pairing.  Also make sure you have only 2.4GHz in  your WiFi and 5GHz is turned off on the router/access point.

- Remove the device from the app.

- press and keep pressing until you get one beep, then two beeps, keep pressing and you should got third one beep.

-Then start pairing.


It is weird that device got registered then went offline straight away.  If the device keeps disconnecting, it is faulty I'd say. I have one 3 gang switch which works only for an hour, then disconnects. After I reset works again for a while. Sometimes gets connected itself. Spent hours troubleshooting, eventually 2 weeks ago I bought another one to replace this one. Good is, from 2.61 firmware onward, stability has improved.

Login or Signup to post a comment