Sonoff Devices Offline Troubleshooting

When you can power up the Sonoff products or other eWeLink supported products normally but fail to control it (offline), the first thing you should do is to check how the LED indicator of your product blinks. Mostly, the offline problem is caused by network connection.

Note: 1.If you change the wifi, you'll need to delete the devices, and re-add them via the new wifi, or they will be all offline.

2.One router can bear a limited number of devices (including phone, PC, smart devices), most routers can provide a normal wifi for about 15 devices, but if the wifi is poor, this will be reduced.

3.After successfully add devices, it doesn't matter what network your phone connects with. But if the wifi Sonoff products connect with is unstable, Sonoff devices will be easily become offline.

Usually, there are three kinds of blinking statuses(here we take the Sonoff Basic for example):

1. The LED indicator quickly blinks one time and repeats (blinks once every 2s), which means the device has failed to connect to the WiFi router.

2. The LED indicator quickly blinks twice and repeats, which means the device has connected to the router but fail to connect to the server.

3. The LED blinks once every 1s, and the device is offline.


The device has successfully connected to the router but hasn’t been added to the user’s account. Please power off the device and restart, then wait for a while. If the device is still offline, please delete it and re-add.


If you have deleted it and tried to re-add for several times but still failed, please try below:


Prepare another phone, enable its hotspot. Use your phone to connect the hotspot WiFi and add devices to eWeLink. If it is online successfully, this means that the problem is due to WiFi. Please check your router settings.

After judging the problem, you can troubleshoot the problems accordingly with below solutions.

Other Issues to Cause Offline Problem

Upgrading Firmware Causes Offline


In some conditions, upgrading firmware will cause MAC address change, then your device will become offline. Below is the firmware list that will cause MAC address change.

Firmware version   
 MAC address change when 
Upgrade to versions higher than 1.5.2
Upgrade to versions higher than 1.5.2
Upgrade to versions higher than 1.3.0
Upgrade to versions higher than 2.0.2
Upgrade to versions higher than 2.0.1

When this happens, please bind your device’s MAC address to your router’s binding list, as follows:

Go to Router Settings -> Close MAC Filter -> Connect your device to the router -> Add the device MAC address to the MAC Binding list -> Enable MAC Filter

If you don’t know about your firmware well, please submit a feedback on the App eWeLink. 

10 Solutions to Failed to Connect to the WiFi Router

1. Wrong WiFi Name or Password

You may have entered wrong WiFi name and password in the pairing process. Please delete the device and re-add. Please make sure you have entered them exactly and select remember password. 

2. Weak WiFi Signal

Your device may be too far away from the router, which causes a weak WiFi signal. Please try again with stronger WiFi signal.

Note: our devices can't connect to 5G WiFi, only 2.4G WiFi supported.


3. Phone Unable to Connect to WiFi

Your router or phone may come across some error, which causes a connection failure. Please make sure your phone can access the WiFi router and works normally. If your phone has WiFi network in the Access Point but the device still fails to connect to the router, please refer to below solutions.


4. Too many devices connect to the AP

There might be too many devices connect to the AP which connects to with the router, please turn off the devices or turn off the AP and try again 


5. Too Many Connections to One Router

You may have too many devices connecting to one router. Most of the routers have connection limit. Please disconnect other devices, then power off and restart your device.

6. Change DHCP Settings

You may have too many devices connecting to one router. Please reset DHCP address pool in router settings, then power off and restart the device to connect again.


7. Router Error

Router error. Please restart your router and try again.


8. MAC Address Prohibited

For some security reason, your MAC address may be filtered and prohibited. Under such a condition, you should remove it from the prohibited address list.


9. MAC Address Conflict

Close all other connected devices to this router and try again.

10. DHCP tenancy term problem

Prohibit DHCP or extending DHCP tenancy term when DHCP is open. 

Under the condition of disabled DHCP or open DHCP, you can extend the lease.

* eWeLink keeps prompting “Network Unavailable”, what to do?

Please ping our server URLs on your PC:
If your location is in Asia:,,
If your location is in EU:,,
If your location is in Oceania:,,,,
If your location is North Ameria or South America:,,
How to ping? Check this tutorial.
If the result shows the connection between the server and WiFi is well, your network is OK.
If the result shows the connections is bad, please change your phone’s DNS to
Still failed? Please change router’s DNS to, then ping the corresponding URL again.
If the result shows the IP addresses don’t run, please send the related URL to your network operator, let them help you. For example, if you are Asian user, please ask the network operator to parse these two domains:,, and


8 Solutions to Failed to Connect to Server

We are upgrading the server or there exists server error. If the server is running normally. Please check below:

1. Unable to Visit the Internet

If the extranet cannot be accessed, then use your phone or PC to visit the Internet. If successful, try to connect your device again.

If you have stopped paying Internet fee or extending your network service, your can’t visit the Internet.


2.Bandwidth Occupied

You may have downloaded too many files at the same time, which occupied most of the bandwidth, thus your device did not have enough bandwidth to connect to the server. If so, please stop downloading and try to re-add your device.

If your other apps can be run normally, only eWeLink display offline, the problem should be your wireless carrier can’t resolve the address of eWeLink server. Please manually change DNS to or, then re-connect.


3.More than one router with the same SSID (name)

You may have more than one router with the same name, and your device may have connected to the non-networked one. In this case, you should reset your router name and choose the networked one to connect. Then try to connect your device again.


4.More than one DHCP server on one network 

There may be errors existing between router topology. In this case, please check the connection way between routers, then try again.


5.ARP Attacked

If you have checked all above and found them no problems, maybe some terminal of the local area network you are locating has affected ARP virus. We suggest you to manually bind gateway and MAC address, then try again.


6.Firewall Settings

You may have opened firewall or some security software. In this case, please temporarily close them and try to connect the device again.


7.DNS Server Inaccessible

After making all above checks and finding them no problems, the possible problem should be DNS error. Please manually change DNS server address and try again.

After making all above checks and find no problems but still failed, the possible problem should be DNS error. Please manually change DNS server address to Then try to re-add your device.

8. IP address conflict

Please close all other connections that connect to the router. Then try to re-add your device.

9. Ping server address to check if server is normal

You can also ping our server address on your computer. Please select the server address according to your location. Then send the result to our support. If you don't know how to ping, please check this post (




Please submit a feedback on eWeLink, describe your problem in details. If you have a hardware problem, please submit a new ticket in our Smart Home Forum. We will follow up on your ticket. 

Our support will deal with your issue as soon as possible in working time. Our working time is Monday ~ Friday, 9:00 to 18:00 Beijing time, Time Zone:8. 

3 people like this

I've just received a couple of BASIC switches and am trying to set them up. I have had them both paired and working intermittently but they are now double flashing which means they are on my WiFi (I can see them on the router) but not reaching the server. Is this a server problem at their end or shall I keep trying to re-add them? I can see them on the server on my phone, but if I try to delete them I get operation failed. More than one phone tried, and also 4G and WiFi connection used on phone.

Sounds to me like a problem at their end!!

1 person likes this
Hate to be the one to break this to you Geoff, but that's been pretty much par for the course since Christmas. There have been a number of extended outages over the last three months (prior to that I couldn't have pointed to a single one). There's bugger all you can do about it until they get their act together.

1 person likes this

Haha thanks for that, I'm glad its their problem not mine, I've wasted hours on it thinking it was me! Is there any way we can verify the status of the servers so we can be absolutely sure it is their problem not ours?

Secondary question, probably rather a dumb one, but if I take the power off a switch and put it back on, it does remember it's settings doesn't it? I mean, I doubt these have any inbuilt intelligence (or CMOS) but their server will identify and label them based on IP or MAC address or something won't it?

Same outage (everyone of my 6 devices offline) here in Italy starting from March 27th evening up to March 28th around 8AM GMT.

I have 5 sonoff in one location/city and they came back online without me doing anything. I have one sonoff TH16 in another location/city (latest firmware) that did not get back online. Same issue on this device due to the outage before this one, I will have to power it off then on again once I get there.

BTW, after the outage, all my scenes have disappeared from the scenes list and are not working.

Well, in fairness you 'could' be at fault too.. But that would be quite the coincidence. If you log into the eWelink app you should see a message saying it's down for an hour(!). Yes, they remember te settings and should reconnect once the server is back on line and do store thier settings if the power is off. If you have any schedules they should continue to run during the outage but you can't change them.

Hello Peter, any idea why the sonoff TH16 "V Temp Hum..."  I have in a different city (see picture above) did not came back online? Thanks. G

"if I take the power off a switch and put it back on, it does remember it's settings doesn't it?"

Normaly there is a setting for that in app and seems working, but don"t know if iTead servers must be up for this to work coorectly and remembering last power state. I had test that with server up and this work.

The biggest problem with those SonOff / iTead deveices are the chinese servers :/


Before I started posting here I'd tried to delete the devices in Ewelink but was getting Operation Failed. Now they've gone and I can't get the bl00dy things to re-add.

I have a life so get on with so will try again later.

Thanks to all for your comments. Forums are so useful.... :-)

But again, before I go out, is there any way we can tell the state of their servers? Maybe once I actually get a connection I can work out the sever name but that doesn't always help. 

I forgot - I did find this server a while back. []

Seems to be significant but as it's up and running I guess it's the services which are having issues...

Mine working and sync in FR.

here are the servers list i found:




...and those,,


mine were all working this morning but seem to have all dropped off in the last 5 mins

So by coincidence I had a SONOFF plug socket turn up an hour ago. Paired and registered really quickly. But when I try to manage it via EWELINK I get network unavailable. Problem is, I don't know which network... The device is sitting there looking ready for action, solid green light, and I can see it in my LAN.

Same from another phone. Also same on WiFi or 4G.

I'll wait a few hours and try again. Unless anyone has any ideas?

...and now it's working a treat...

Something's kinda flakey!!!!

Do you still have your scenes? All mine scenes disappeared this morning
Login or Signup to post a comment