Start a new topic

Sonoff looses Wifi connection

Hi,


My Sonoff has the problem that it frequently looses the connection to "the server".


When I Power on the Sonoff it connect to "the server". After some seconds the green LED is constantly green, and the Sonoff can be switched on/off via the App.


Some time (sometimes a few minutes, sometime 15 minutes) later the the green starts blinking "fast", and the App reports the device disconnected. Waiting for a reconnection does not change tis, it stays unconnected.


I checked that the Wifi Router is working.


When I remove power from the Sonoff and power it up again, the Sonoff "boots" and after some seconds the led is constantly green again, and is accessible by the App.


In this way the Sonoff is not able, so what can I do? I guess the Sonoff should reconnect automatically, or this not implemented?


Regards.



19 people have this problem

I have 14 Sonoff devices and found the new model (the full white wit RF) problematic. One day I bought 2 1 gang switches, one worked fine out of the box another one kept loosing wifi. Seller replaced. Then I got 2 gang... same story... got replaced... the replacement crashing every 2-3 hours then reconnects it self. Didn’t even ask fir anither replacement. Also for the white model, I had to install another AP because it was not connecting to the one I had already where the old switches (white with black frame) work perfectly fine... currently I have one switch which works for 2-5 hours then disconnects and need to be restarted and one which looses connection every 3-4 hours but reconnects it self... I think quality check in Itead is no longer as high as it used to be... from my experience from the last 5 purchases, 20% devices are broken out of the box where before had no issues what so ever

I had no problems until :


1  I upgraded the firmware

2  There was the Chinese New Year

3  Sonoff made a server upgrade


Does anyone know which of these changes (if any) is the cause of the problems ?

I think it is a hardware.. I have two same 2 gang switches, one is working w/o any problems, loses connection maybe once a week for few seconds.. Another one, exactly the same model (the one I already replaced) is disconnecting every 2-3 hours and since yesterday even more often. Both are running latest firmware.
Also, I was not able to pair this one in the way I paired the other, I had to use AP mode.
And even more, I was not able to find this devices listed, until I kept pressing button so it started blinking constantly (not like in Pairing mode). I think this is a second mode for pairing but didn't find details.
I recently bought another 3 gang switch, didn't test yet :)

 

Please refer to following methods if you device never online:

0.Our device just can be used with 2.4G network. Device need time to be online when pairing successfully.

1.Please refer to following link: http://support.iteadstudio.com/support/discussions/topics/11000001238


2.Not connect to wifi:

 1)Please check the SSID and password, make sure they are entered correctly?

 2)try to power off the device and router for some minutes ,and power them again.

 3)Try to Make a smart phone as hotspot connect to Internet,use another smart phone connect device to this hotspot.

4)Your wifi name and password should be in English letters and numbers. No special letters allowed,and have better the length don’t beyond 20.

 5)Please try to make your router haven’t password to connect device.  

 6)Change SSID channel to unique.

 7)Disable router MAC filtering

8)Try to Change the router wireless setting from mixed mode 802.11g/802.11n to 802.11n only.

 9)Or Try to Change wifi 2.4GHz network to WPA TKIP mode or no security mode.



3.Not connect to router:

 1)Try to ping our server:eu-disp.coolkit.cc(in EU), us-disp.coolkit.cc(in US).




For device ever online,please refer to following methods:

1.Please make device close to router

2.Disable the MAC filtering.

3.Try other router.

4.Please Unplug the device for several minutes, then plug it to power up again.

5.Try pairing again.

6.Try to change the router name to pairing again_ can it work?

am having the same problem with the recent purchase of t1 3 gang, keeps on disconnecting switches on and off automatically the lights when not connected to a router.

Unfortunately after acquiring 18 switches (wall, plugs, switches) I'll have to ditch sonoff/itead devices once and for all. This is my story: one WiFi switch melted driving a 10W load, another cannot hold a connection more than a few minutes, several wall switches lose connection and I need to cycle power them off from the main fuse cabinet to get them back online, two wall switches autonomously and randomly (every few hours) turn off the lights, one wall switch lost the indicator red light, so cannot be seen in the dark and frequently the ewelink app crashes and Alexa integration fails. What a nightmare!
I stopped using sonoff. Always problems and it make me nervous
I tried all methods, different AP, changed encryption to WPA, still the same. This particular one goes off line from time to time with no patern. All other devices from time to time go to I called sleep mode. They look on line but when you try to change status to on or off it says that can’t connect. Few seconds later, the device gets off line and then on line and works fine. Same story with all the devices including RF bridge. Also discovered that sometimes when I turn on the device with Alexa, it does not update status on the eWelink interface, so lamp goes off but on eWelink is still on
Lads, the latest firmware update fix stability a bit, it is still going off-line but less often.

 

Hai paura di rimanere col tuo Sonoff senza internet e non poter accendere e spegnere i tuoi dispositivi ? Scopri come fare con la modalità LAN grazie alla mia guida completa.

 

Sonoff senza internet: modalità LAN guida completa

My Sonoff switch is frequently disconnected from the wifi router. I have tried to upgrade its firmware version but its failed... Please suggest a solution.
I am getting this message...
check if you connected the live and neutral wires in the right places.
@Khaled Keep trying, if still an issue, connect switch to your phone as hot spot then try to upgrade from another phone
check if you have connected input live and neutral wires properly. then if you have the firmware to 1.6.0 then use compatible AP mode by pressing the sonoff button for 5 secs and again for 5secs until you get fast bkinking green light. then update the device then dete it and add it again in simple touch mode... that will do the job :) follow the video below... https://youtu.be/iCRq5obr_SE
Login or Signup to post a comment