Start a new topic

Error adding Sonoff to server

Hi I ordered 7 Sonoff wifi switches but so far havent been able to add them to the server. The error is after the device name is entered and says " add failure". The light blinks twice fast like its connected to wifi but not to server. Router is operating correctly. please help!

20 people have this problem

Good morning,

I live in Brazil, this week I bought two devices (Sonoff 4CH). One of them is not connecting to the Server.

Both devices are getting IP address and connecting to the router.

I did the following troubleshooting :  

Another device works in the same conditions

Ping Servers Ok

Restarted device

Disabled Firewall 

Changed DNS

Turned off all devices in my network, except for Cellphone and  Sonoff.

Could you please help ?

Thanks in advanced.

add sonoff to server error

Hi there, we have checked, the data now has synchronized. Now please try again and tell us the result. Thanks!

Hi there Help please. I try to pair my sonoff, so the green light must blinking all the time and try to pair with the app the process starts and suddenly the green light stops blinking all the time and blinks 2 times fast and stop for a second and this go on and on. The app says communication error can anyone help me please. The device has problem? I do something wrong? Because when I buy it I didn't know that I must be an Internet guru to pair the device.
Hello, I have the exact same problem as bobbytod. I walked through the process as he did, but did not succeed. Can you please help me get the sonoff online?
Hi RJK Make sure you are using AP mode to connect to WiFi. Once connected locally (wi-fi) is EWeLink is showing the switch as offline switch off the device for about 10 mins. This gives time for the ITEAD server to update your account. Turn on again and see if it connects to both Wi-Fi and server. If not all you can do is delete the device and try again. Personally I moved some of my critical stuff to tp-link devices which seem more robust in connection.

steps are as follow:

1.use your cellphone or PC/iPad/laptop to surf the internet with your wifi,checking the internet is workable or not.

2.please close every Download tool to avoid occupying the bandwidth.

3.If there are more than one routers in your home and the routers' SSIDs are same, please change them to different SSID and connect your sonoff to a workable router.

4.If there are more than one routers in your home,please check the linking method between routers.

5.check if your PC/laptop is attached by ARP

6.please check the firewall is available for Sonoff

7.If you check every single option forementioned and the problem still does not solved,please reset the DNS Server address manually

8.please do not use other device to connect the WiFi when you pairing the Sonoff

by the way 

could you please tell me which country do you live in 

Thanks for you answer. Unfortunately it does not work. Where and how do I delete the device? 

i got a single switch wifi sonoff product.


i had complited configuration in one mobile.there is a problem in connection some time it blinks green ones than after twise quickly and than continue on. but not working properly from mobile some time it works and some time not work.


sir please give the solution for this problem


I had activated itead "first generation device" which worked perfectly for 4 days. Now it shows that the device connected to the router but did not communicate with the server. I erased item from my account and tried adding it again. I am unable to add it. Tried connecting thru wifi directly to device but does not work and goes back to blinking fast twice. How can I "hard" reset the device?

Hi, I bought 2 devices Sonoff and I have not problem with them. Then I bought 2 new Sonoff POW and I can not add them to ewelink. Device just looses connection all the time. Please help. I have tried all advices found here. I tried 2 more routers, one quite old , nothing. I tried different phone Sony x5, Samsung S7 - nothing. I have no ideas now.

I registered an account just so I can help others on getting a Sonoff paired.

After trying for hours and using AP mode, pairing from fresh power up, trying to pair to WiFi without special characters in, pairing to a mobile phone hot spot, etc. etc.  The ONLY thing that worked STRAIGHT away, was to put the phone into airplane mode, then only activating the wifi to connect with home router, then running the app to pair, and it works!!

The system of putting the phone in airplane mode also tried it and it did not work for me.

Hi there,
I am using a samsung s-duos to pair Ewelink  with my sonoff switch,Despite pairing, my device stays offline.I have tried powering it on and off but still it doesnt come online.I have also used previous versions of E-welink but still no new result.I am running out of time,how can i Fix this,is there a way?


Login or Signup to post a comment