Start a new topic

Error adding Sonoff to server

Hi I ordered 7 Sonoff wifi switches but so far havent been able to add them to the server. The error is after the device name is entered and says " add failure". The light blinks twice fast like its connected to wifi but not to server. Router is operating correctly. please help!

20 people have this problem

This problem affects all Sonoff devices. I have had all 3 of my devices working fine for a few hours only to return to them and find the are stuck on two flashes. THIS IS A SERVER PROBLEM. The customer cannot change this and there is NO CURE. I am going back to TP-LINK devices which actually work! Sonoff devices can be re-flashed with different firmware that does actually work but this is a poor solution for non technical types who have bought these devices in good faith. These devices will apparently go on or off line with the server at random intervals and there is nothing the customer can do about it! In a distant future maybe there will be a way for the user to change the server used to one suitable and local enough to provide switching reliably. In the meantime buy another product. These devices are cheap but probably useless to most home automation applications. Technical support does not exist and certainly not for Europe. The replies given on this forum all say the same thing which DOES NOT WORK and con to solve the problem. Reflash the Rom with something that works and it’s not a bad switch.
Which TP-Link device would you recommend instead of Sonoff POW?


Hi there, we are sorry for this problem.If you don't mind, please offer us your account number and password for testing. We will check the problem and try to slove it. Our email address is

You must be patient.  server is in europe when you are in europe. working fast and good till yesterday.  Sometime you must clean memory in your phone when you see on your phone that  is not connection and you can not see light in sonoff device. Ifyou can see continous light in your sonoff  device and in your phone in ewelink you see that is offline it means that problems is in your phone -  close all aplications ,clean memory ,and then reopen ewelink aplication. It help. If still blinking your sonoff  device it means that problem is with server or your wifi home network. If your wifi is ok it means that problems is with server evelink and you can do nothing. I repeat you be patient becouse yesterday and today is realy problem with server and I belive that after New Year all come to good work and problems will be resolved.
Personally I am using h100 plugs to feed multi-socket strips. The H200 light switch looks like a good lighting control if rather basic. I have one on order so I’ve not had a play with that yet! These are NOT CHEAP! But if they work well it may be worth the costs. I have 3 plugs and need 3 light switches to cover my control area. To get away from automating everything I have fitted LED PIR motion detector bulbs in the passageways of the house. Lights come on if someone walks in and go out again after a few minutes.

I tried to add a new Sonoff Basic into my existing list but couldn't get it to work. App showing offline but I realised Alexa discovered the device. I think it hooked up onto my router but not register to the server. The device blinks 1 time every 1 second. 

This is ridiculous, we can't relia on this. How many times its been down and there's no notification before upgrade work carry out. I've been chasing all day I thought Internet causing issues. Itead Need permanent solutions.

Don't waste your time. Just wait until they fix their servers. The same thing has been over New Year and it took about 2 weeks for everything to go back online.

hi thanks for your response. the light stops blinking fast as soon as i put in my device name amd error comes up. my wifo network is working fine throughout the process. i am using android. i tried 4 different phones and 3 different wifi networks. including one on a different router.
here is a screenshot of the error.
picture 2.

I've tried for many times and for may methods to pair a new sonoff device, the device pairs, appears on the app, but everytime appears as "offline". F*cked rubbish.

I found that everyone here distributing knowledge so, why not me I want to share the fact that if you are searching for authentic vapes then Vape Store In Pakistan will be your last stop.

(30.2 KB)
i can connect using default password "12345678" if the Itead wifi configuration is set to static not DHCP.
and then pair it using ewelink app.
it works for me.


Hello, I have bought 5 sonoof, but its only possible to connect 1, why? I have Updatet 5 and they Will not work, Can you reset my data, Can se that it helps other. The one working is not updatet...... Thanks
Login or Signup to post a comment