Start a new topic

Error adding Sonoff to server

Hi I ordered 7 Sonoff wifi switches but so far havent been able to add them to the server. The error is after the device name is entered and says " add failure". The light blinks twice fast like its connected to wifi but not to server. Router is operating correctly. please help!

20 people have this problem

Today 20/02/2018 this morning ally sonoff devices offline. Failed to connect. I've tried to reload and didn't work. Error message check network connection. Look like server down or firmware issue. Help me.

send an email to support with the ID of the devices (through the app)

green light on it LIGHTS ALL THE TIME (no blinks)

anybody know something?

Hi Julio A. Jorge,

Did you read the troubleshooting post? Hope you can solve the problem by reading the post. If not, then you should submit a feedback in eWeLink, the support will check out the problem and reply you.

I have the similar problem. All devices goes offline and can't connect tot the server.I have also trouble to log in to the eWeLinik app. So, this is definitely ITEAD server problem. Seems that this devices are not for EU. I got offline 3 times in 5 days. To put it back online first time I re-install the app and pair it again. The second time I need to power everything off and then also delete devices and pair it again. Work after a lot of attempts. Maybe is this because is New Year and servers are overload. But is very frustrating using this products. Seems that are not done well.

Servers have been down since 8am today. Android app gave message in app saying servers were being upgraded and to come back in a couple of hours. Servers came back online at 10pm here. Still can’t get device list from the app but all switches are now connected and working with Alexa. If you are trying to setup a new device I’d wait till tomorrow to see if the app is working and the servers are stable before trying. If the server is dropping out or the app is losing connection then you won’t stand a chance! Back in January the servers were up and down for nearly two weeks so don’t hold your breath.

No they're not using it.

I bought it yesterday, so this is the first time it's used.

Please feedback this issue on ewelinkfeedback,my APP department colleagues will help you.They also need your feedback record. 

(266 KB)
Buongiorno ho 5 moduli sonoff 3 funzionano benissimo , mentre mentre gli altri 2 dopo avergli eliminati dall'app eWelink non si riesce a fare l'accoppiamento.
Yesterday and today still problem with connecting to server . Before till yesterday was any problems , all worked 100% fine. Probably because is New Year and servers are overload.

Then you should submit a feedback. Our IT support will check and reply you.

Purtroppo l'accoppiamento dei sonoff è un tasto dolente. In alcuni casi ho perso parecchie ore per questa operazione. Pur seguendo tutti i suggerimenti da parte di ITEAD molte volte il problema restava. Ci vuole molta pazienza

I hope you are right Andrzej Konopacki and this is because of New Year and holidays. Seems that will be the best to flash the devices and have the own server :)

@iman: it looks like your phone is not being assigned an IP address correctly. I had the same problem, and noticed I could connect via WiFi from a Pc, but not from my iPhone. Next time I'll try by setting a static address. 

Login or Signup to post a comment