Start a new topic

Error adding Sonoff to server

Hi I ordered 7 Sonoff wifi switches but so far havent been able to add them to the server. The error is after the device name is entered and says " add failure". The light blinks twice fast like its connected to wifi but not to server. Router is operating correctly. please help!

20 people have this problem

hi thanks for your response. the light stops blinking fast as soon as i put in my device name amd error comes up. my wifo network is working fine throughout the process. i am using android. i tried 4 different phones and 3 different wifi networks. including one on a different router.
here is a screenshot of the error.
picture 2.

steps are as follow:

1.use your cellphone or PC/iPad/laptop to surf the internet with your wifi,checking the internet is workable or not.

2.please close every Download tool to avoid occupying the bandwidth.

3.If there are more than one routers in your home and the routers' SSIDs are same, please change them to different SSID and connect your sonoff to a workable router.

4.If there are more than one routers in your home,please check the linking method between routers.

5.check if your PC/laptop is attached by ARP

6.please check the firewall is available for Sonoff

7.If you check every single option forementioned and the problem still does not solved,please reset the DNS Server address manually

8.please do not use other device to connect the WiFi when you pairing the Sonoff

by the way 

could you please tell me which country do you live in 

Thanks for your reply.

I live in Australia.

1. I have checked the wifi with a number of different devices and can confirm that there are no issues with accessing the internet.

2. I have closed (shut down) every other device on the network and only connect using Sonoff - still no success.

3. There is only one router with 2 SSIDs (one is for 2.4G and the other for 5G). I switched off all SSIDs and only left one new SSID for purpose of testing. My mobile and laptop connected to the internet fine using the new SSID, but sonoff still failing to add. I also took the device to my brothrs house and  tested there to make sure it is noit my netwoprk - same issue occured there suing both his and my phone.

4. Only one router.

5. I am not sure how to do this (laptop attached by ARP). The laptop and every other device on my network connect fine and are visible under "Attached Devices" in my router. I can also see the Sonoff in "Attached Devices" which tells me its connecting fine to my router, but cant connect to the server.

6. Firewall is fully disabled for purposes of configuring this device. No success.

7. I have manually entered DNS details provided by my ISP in the router. Everything else still works/connects with no problem. Sonoff still cant connect to server.

8.I have disconnected WiFi from all other deviecs, including the device i am pairing from. Still same result - App shiows either "Device does not exist" or "Add failure" once i press nxt after entering the name.

I have made a video of the process if you would like to see.

1 person likes this

Hi there, we are sorry for this problem.If you don't mind, please offer us your account number and password for testing. We will check the problem and try to slove it. Our email address is

Hi there, we have checked, the data now has synchronized. Now please try again and tell us the result. Thanks!

Just want to confirm that everything is working. Support has been excellent - thank you very much!

I'm having the same problem. Can you reset my data too please. It worked fine initially but now I get "Device offline" and light flashing quickly twice.


1 person likes this
Three days later and still no help. This product "support" really sucks.


1 person likes this

I've got problem with my sonoff. When i pair it with my phone, it says " device belongs to other user".
Does anyone knows what's the problem ?

1 person likes this

@Nermin Boja The device has been added already. Please ask if your family or friend has added it or submit a feedback on ewelink.

1 person likes this

No they're not using it.

I bought it yesterday, so this is the first time it's used.

Login or Signup to post a comment