Start a new topic

Using Google with seperate on and off switches in RF Bridge

I have a RF light switch which has 2 buttons on the remote, one for turning the lights On and the other to turn them Off.  I have mapped the 2 buttons using the RF Bridge and labelled them as ON and OFF in the app.  

When I say to Google "Turn on Office Light", it responds with "Turning on 2 lights".  The lights turn on.  When I say "Turn off Office Light", it responds with "Turning Off 2 lights" and then the lights turn off and then back on.  I assume that the buttons are being treated as toggle buttons for 2 lights and the On and Off commands activate both buttons.  It just happens that the On button activates after the Off button.


Does anyone know how to configure it so that the "Turn Light On" command only activates the On button and the "Turn Light Off" command only activates the Off button?


I have somewhat similar issues, except what when Google replied with "Turning on Garage Light On", nothing happens. The RF Bridge works well with eWeLink app, able to turn on/off this light with 2 separate buttons.


Graeme: Do you happen to have created a Scene in the App to trigger this event? Maybe there is a trigger to turn it off?

image


image





Hi Aaron,

No - I don't have any Scenes configured.  Mine fortunately just works with the buttons configured.  It may be that the lights are being turned on and then off as both buttons are activated.


I have done a workaround which enables me to get the light turned on without it being turned off again:

  • I have mapped the 2 buttons from the remote into the RF Bridge calling the Remote "Office". 
  • I named the button that turns the light on as "MainLight"  
  • I named the button that turns the light off as "MainLight Off"
  • In Google Home, I created a Shortcut so that when I say "Turn On Office Lights" or "Turn Office Lights On", etc  Google Assistant will do "Turn On Office MainLight"
With this set up, when I say "Turn On Office Lights", Google turns on the light and says "Sure Turning the Office MainLight On".  When I say "Turn Off Office Lights", Google turns off the light (actually turns them on - but they are already on, and then turns them off, and responds "Sure - Turning off two lights".  I could set up a shortcut for turning the lights off too, to prevent the turning on and off.

It is not perfect, but it works.  It does mean that there is a lot of setup though if you have lots of lights.  

Same problem here, kinka annoying to say "turn on" to turn off.

Used some aliases but they are not usable bay everybody.


Yes this is really an issue when using it with Google Home. I guess this is an issue that cannot really be fixed?

Login or Signup to post a comment