Start a new topic

RF pairing to remote

I have my device connected and working but can not get it to link to any RF remote. I double tap the little switch as directed in the instructions but the led does not flash red. Any help appreciated.

6 people have this problem

 Hi, I have the same problem.

I bought Sonoff 4CH Pro and connected it to wifi properly.

I then bought a remote control 433 mhz and it has no codes stored in the 4 channels. I can not connect this remote to the receiver

I also have another remote control (same as the first one) that has two stored codes of two home automated gates. These channels (with stored code) I can associate them with the Sonoff 4ch pro without any problems. The remote control works and I can turn off the two connected channels

In my opinion the problem is this:
if the remote control is new and does not have associated codes does not send them and therefore the receiver on the Sonoff receives nothing and does not program corretly.

Does anyone know how to generate random codes to associate them with the remote control and then send them to the Sonoff?

Now if you press the button on the active remote the channel Sonoff (kitchen light), but also opens the gate of the house !!!!!!

Thank you all


Any update on this problem, i can get the red light to flash once, you have to watch carefully to see it, but it does not learn the code of any remote.

The above video does not work either??


1 person likes this


I found the solution in this video: SONOFF RF SWITCH INSTALLATION, WIFI, 433MHz Remote, Alexa Voice Control Setup

But the steps are easy (once you know):

  1. Press the Sonoff button 10 seconds (until it starts blinking).
  2. Press the Sonoff button twice quickly.
  3. Press remote RF button and hold until a red/green blink is seen.
  4. The Sonoff will return to working state (repeat for additional remotes).

You can erase all configured RF remotes by pressing the Sonoff button three times (after the long 10 seconds press).

You can exit from pairing state pressing once.

Note: Make sure the remote is 433 mhz (It can happen).

 I've bought several Sonoff RF units. All devices are connect to WiFi and working fine via eWeLink app, but just SOME of then I succeed to add a RF remote.   


       I have tried to pair with 433MHz remote using instructions provided -  ie. press button twice rapidly to place in pairing mode -  and the red LED goes ON but no pairing success. I also tried pressing button on RF board for 2 sec but still no result.  Relevant info:  SOME of the units I could update the firmware version from 1.6.0 to 1.8.1 and SOME other I could' t do it - However, all devices (1.6.0 and 1.8.1 versions) are showing the message "latest version" on eWeLink software.

   Someone could help with this?  Thanks.

Login or Signup to post a comment